1
\$\begingroup\$

I've got the following data after running the Unity Profiler:

Profiler output

If I'm reading this correctly, the thing that's driving me down to ~1 FPS is the CPU Audio. I can't understand what's going on here, though, because there isn't any audio in my game right now.

\$\endgroup\$
1
\$\begingroup\$

tl;dr: The Audio (WASAPI) Feeder isn't doing anything; it's just sitting idle. Something else is using the time and, spoiler alert: it's the GPU.

Here are the steps:

  1. Ensure that GPU profiling is enabled
  2. If GPU profiling gives you an error like, "GPU profiling is not supported by the graphics card driver," then enable "Graphics Jobs (Experimental)" in the player settings (details later)
  3. Re-run with the GPU profiling enabled.
  4. Notice that, in the GPU profiler, the rendering is what's taking all the time.

For me, I am developing on a laptop with a mobile version of an nVidia card, which seems like might be the reason for the GPU profiling error, and then I'm guessing that error is why GPU wasn't listed with the other profilers.

I noticed that "Other" took all the time in the GPU, but I realized later that "Other" is the editor, because I was using the Scene window to move around the scene. When I clicked over to the Game window and moved the player camera through the scene then the GPU rendering went from "Other" to "Opaque."

Finally, here's where the Graphics Jobs (Experimental) setting is located:

Graphics Jobs (Experimental) setting location

| improve this answer | |
\$\endgroup\$
  • \$\begingroup\$ I spent about 4 hours googling around for this problem, thinking the WASAPI was doing something, but couldn't find any answers online. I'm hoping this answers the question for someone else down the road. \$\endgroup\$ – Chuck Apr 8 at 16:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.