0
\$\begingroup\$

This has been asked a few times, but none of the answers worked; also, the other questions are very old. I have an object with a mesh collider on it. In the editor, the collisions work completely fine. However, in the compiled game, there are no collisions at all. It is important to note that other colliders (box collider, sphere collider, etc) work completely fine in both the compiled game, as well as the editor.

The mesh is the following: enter image description here

What I've tried:

  • Recreating the entire prefab that has the collider.
  • Remaking the mesh for the mesh collider.
  • Using a different format for the mesh (.fbx, .obj, etc)

Additional Details: - The object has a rigidbody, and a mesh collider that is convex.

  • The object is moved via script, using the velocity of the rigidbody.

  • It used to work completely fine until I scaled everythig in the scene down by a factor of 2. So, I opened up Blender to half the size of the mesh. Regardless, the problem is not the mesh but the fact that it works in the editor and only the editor.

\$\endgroup\$
  • \$\begingroup\$ Can you show us your mesh (or a sufficiently representative stand-in), how you've configured its collider, and how you're moving the objects that collide with it? \$\endgroup\$ – DMGregory Apr 3 at 2:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.