0
\$\begingroup\$

I built out my project to Android to do some testing and stuff, but I can't get any further than the main menu scene. I built it out previously and it was running fine. Now as I try loading level0 it crashes with no error messages from adb logcat. Just exits the game and that's it. It works fine in the editor.

I tried several things. I changed the color space back and forth, I built my addressables, tried development built and non development one, and the Split application binary checkbox is false as well...

Unity 2019.2

My adb catlog output

\$\endgroup\$
  • \$\begingroup\$ What Minimal Complete Verifiable Example would allow us to reproduce this error ourselves, so we can test potential solutions? Try making a new empty project and adding just the bare minimum you need to it in order to cause the crash, then document the steps you took to get to that point. This will help us isolate and fix the problem with minimal guesswork. \$\endgroup\$ – DMGregory Mar 27 at 11:13
1
\$\begingroup\$

Reading your log output, it seems your application is having trouble loading your assets from the device storage. A few suggestions I can make:

  1. Make sure your application has been permitted to access storage in your android device. You can try this, and if your app isn't listed there, try removing it and re-adding it to your device. Android should ask you to give permission to the app.

  2. How are you loading your assets? If you're prefixing the path with "file://", try removing it from the path. (Suggested here)

  3. Check your assets paths again, they could be wrong. I'm taking about the paths you send as argument to your asset-loading functions in your code. Watch for case sensitivity.

  4. If nothing works, you could maybe workaround this by selecting your addressables group, and under the properties, there's a retry/attemps field you can set to 3 or more. Then build the bundles again. (Suggested here)

I built it out previously and it was running fine.

Built it to android? Or another platform like Windows? This distinction can narrow down the reasons for the error. For instance, the first thing I said isn't relevant if the previous build was for Android and it worked fine then.

| improve this answer | |
\$\endgroup\$
  • \$\begingroup\$ I am not using AssetBundles, I am using Addressables, and my prevoius builds were Android as well, and they worked fine. I set the retry field to 4, with no luck... Trying to reproduce the error somehow. \$\endgroup\$ – formatc2013 Mar 27 at 15:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.