0
\$\begingroup\$

I have released my first title Audio Infection ( https://store.steampowered.com/app/911580/Audio_Infection/ ) for a bit over a year ago. Recently 1 user has so far encountered an issue where the game does not launch. He is the only user that encounters this problem.

He has this issue on both Win 7 and Win 10. His system specs are fine and his drivers are up-to-date. The game does not leave a log file, rather it looks like it is unable to boot. There are no Windows error reports on it either. I watched it through Discord screenshare because I could not properly understand his issue.

I had asked a few other random people to test my game and demo (he has the issue with both, the demo and full version) however no one else (including me) is able to reproduce this behavior.

At this point I have tried:

  1. updating Unity from 2018 to 2019 (no change in behavior)
  2. added manual logging (with no results)
  3. updating drivers (on his system)
  4. installing Visual C++ (on his system)
  5. empty project with Unity sample scene (he was able to load the sample scene!)
  6. deleting crashhandler.exe (used to fix similar issue in the past based on older threads)
  7. modifying files
  8. deleting and downloading the files

What else can I try in order to figure out what is causing the issue? I am honestly clueless. Since the sample project was able to boot on his system there is definitely something wrong with the build on my end. However he is the first person with this issue. It doesn't even get to the point of launching on his system and it can't be found in the memory either. It is almost as if Windows is blocking it from launching, however that is not the case. But the result is very similar to that.

There is a free demo on the store page available in case you want to see if it boots on your system. It works for both VR and non VR systems. When no VR devices are detected all VR related contents are disabled. This has been thoroughly tested and worked on loads of different Windows systems with different specs, with VR and no VR.

Once again, there are no errors, no logs, the build doesn't even make it to that point, yet that exact same build works for literally everyone else on various systems. I am absolutely clueless about what to do in order to resolve this issue. Any help/advice or pointers towards the right direction are greatly appreciated!

PS: he is not a troll, I have known this guy for a long time now and he genuinely wants to support me.

\$\endgroup\$
  • \$\begingroup\$ Have you tried gradually adding settings & content from your game to that empty project, sending builds to try launching until you find one that breaks? That should help you narrow down what ingredients are responsible for this behaviour, and let you craft a Minimal Complete Verifiable Example you can share here for troubleshooting. \$\endgroup\$ – DMGregory Mar 7 at 13:14
  • \$\begingroup\$ There is a free demo available that can be used for testing by anyone, he is the only person so far that is experiencing said issue. Thanks for the suggestion, but I would rather not try to manually add things one by one to an empty project as it could be a progress of literally months due to the amount of mechanics in the project and the amount of time I can dedicate to this per week. If this would be the only way to debug then I unfortunately would be required to drop this issue since I simply do not have that amount of time. If there are any other possibilities I can try then I am all ears. \$\endgroup\$ – ploopploop Mar 7 at 18:56
  • \$\begingroup\$ If one person experiencing the bug leads to no errors or log output that's been of any use in tracking down the issue, what would lead you to believe that more people downloading the same demo would somehow yield more useful information? You're absolutely right that isolating the problem step by step can be a long and arduous process, but it's also your very best shot at discovering the cause. And it's also your responsibility as the creator of this app and beneficiary of this debugging process — Internet strangers have no stake to invest this kind of time on your behalf. So it's up to you. \$\endgroup\$ – DMGregory Mar 7 at 19:10
  • \$\begingroup\$ I am fully aware of that, I was just hoping if I could reach people with this that have had similar issues to date. From those there is a possibility that one managed to solve said issue and might be able to point me towards the right direction. Time wise that is a lot more efficient for me. By no means am I asking anyone to debug my project (apologizes if it looked like that) or spend more than 5 minutes on this. I am simply looking if someone has had a similar issue and managed to fix it or figure out the cause of it or has any information at all about it. Sorry if I gave the wrong idea. \$\endgroup\$ – ploopploop Mar 7 at 19:28
  • \$\begingroup\$ The symptoms we have to go from so far are too limited. You might well meet 100 developers whose games have failed with this same symptom, but with 100 different underlying causes that don't apply to your project. That's why we'll need you, as the only person in this equation with access to the source, to narrow down the set of potential causes and show us what under-the-hood details you've determined are contributing to the problem. \$\endgroup\$ – DMGregory Mar 7 at 19:30
2
\$\begingroup\$

It took me 3 months on and off working on this issue, but I have figured it out.

The issue lies with OpenVR/SteamVR. The head tracker of Steam has 2 camera's; head and eyes.

This is where the instability comes from, for some systems (even if VR isn't used and toggled) it prevents the build from starting. It will not throw any errors. For some systems it will be a bit slow but still stable.

The cause of this issue is the fact that the head camera has by default no background type. By setting background type to sky (or color) you fix this issue.

Hope this helps for anyone in the future that comes across this or a similar issue, good luck!

| improve this answer | |
\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.