I'm using Ubuntu 18.04.4 LTS and I went through the instructions on this page: https://www.monodevelop.com/download/ very specifically, (yes, I made sure to use the steps for the correct operating system, and I did all of the steps at the bottom, I have all certificates and performed all fo the updates).

I then opened monodevelop and went into tools and downloaded the monogame extension.

Then I was able to create a new solution of type MonoGame... the options are: Cross Platform, iPhone/iPad, Android, Windows, Mac, and tvOS. Apparently there isn't even support for Android at all so I don't know why that's even an option. I then tried Cross Platform, and am now trying Windows Application... And when a make a solution for either of these files and just try to build the initial boiler plate code that they give me, I get the following error as demonstrated in the image below. Does anyone know how to get these assemblies? And why are all of these files missing? I deleted Monodevelop from my machine and reinstalled it from scratch and tried again using a new solution and it's all the same. Is game development for MonoGame using MonoDevelop on a Linux machine even possible?

enter image description here

  • \$\begingroup\$ I went to this webpage: community.monogame.net/t/monogame-3-7-1-release/11173 which is where I first downloaded 3.7.1 for Linux and ran the .run file that gets installed, and things are working now. Previously I was on THIS other page: monogame.net/downloads and I had used the link which is labeled as "MonoGame for Linux" and had been using that... which I thought made sense because I'm using a Linux machine. But now that I'm using the other version my errors have all gone away except for one "invalid configuration mapping" which isn't technically an error. SOLVED. \$\endgroup\$
    – user136358
    Feb 29, 2020 at 22:34
  • \$\begingroup\$ You can post your own solution as an answer on your own question, that way we know the question has an answer. :) \$\endgroup\$
    – Steven
    Mar 4, 2020 at 7:35


You must log in to answer this question.

Browse other questions tagged .