3
\$\begingroup\$

I have made a grid using multiple planes. Now I want to place a image on this grid so that user cant see the grid I have made and I ll have access of all points of the image using grid.

The problem is I am unable to place image on it, it shows me grid that I made before. I have tried Materials/Shader -> Transparent/Diffuse, but some blocks are still visible. How can I make grid tiles transparent ?

\$\endgroup\$
  • \$\begingroup\$ can you share some image of your problem? \$\endgroup\$ – Ali1S232 Sep 30 '11 at 11:40
  • \$\begingroup\$ I am still having problems, I will try to upload the image. Basically problem is: I have multiple planes just like 2D array and I am placing my simple background over the grid, but on playing there are all the planes(Grid) displayed which I dont want the user to see. I only wants the user to see map(my background image) not grid. \$\endgroup\$ – Syed Sep 30 '11 at 20:56
  • 1
    \$\begingroup\$ Can't you just skip them in your rendering process \$\endgroup\$ – Ali1S232 Sep 30 '11 at 21:03
1
\$\begingroup\$

Without an image of the problem it is fairly hard to answer, but if it is a rendering problem then add the image render after the grid render or just skip rendering the grid.

| improve this answer | |
\$\endgroup\$
1
\$\begingroup\$

As Gajet mentioned, you can simply remove or disable the MeshRenderer Component off all the tiles/planes you not want to show. (They still exist for collisions, but will not be visible.)

| improve this answer | |
\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.