0
\$\begingroup\$

I am missing all the animation options in the Animation tab in the Inspector Window when importing FBX files.

In the picture below, there are only 2 checkboxes. I can't see the list of animations, options, animation events etc., but you can see on the lower left window that the animations we're imported. Also, the Materials tab is empty as well.

This FBX was exported from Blender. If I directly drag the .blend file to Unity, all those tabs appear normally, but when dragging an FBX, they become empty. I am using Unity 2019.3.0f6.

enter image description here

\$\endgroup\$
0
\$\begingroup\$

These are NOT solutions to our problem, but work-arounds.

METHOD A: Using only Unity 2019.3
After noticing that Avatar Definition its empty/none byt default in 2019.3 I used Create From This Model to have an actual avatar to deform my model:

Avatar Definition its empty/none byt default in 2019.3

Then, in order to define loop time/pose and clean up animation clip names, I had to CLONE (ctr+D) all animation clips in the Project window and apply animation clip attributes into the cloned one, like this:

cloned animation from fbx source

Now you can have your animation clips working in your model.

METHOD B: Using only Unity 2019.3 + 2019.2
Import as always your FBX in a Unity 2019.2 project and be sure to go to Animation Tab in the inspector of the FBX, and mark any checkbox that force you to apply changes (in my case I checked Loop Time in Idle animation clip), now the metadata file will be updated with the info needed by 2019.3. Create a custom package and import it to your 2019.3 project, all the meta data and import properties will be there this time like shown in the picture below:

enter image description here

Hope this helps and that Unity guys fix this bug. This doesn't look like a configuration issue but a problem in this new version.

| improve this answer | |
\$\endgroup\$
  • 1
    \$\begingroup\$ Thanks, yeah I was able to make it work using Method B but instead of creating a package, after I edit in 2019.2, I just copied the fbx and meta file to my project directory in 2019.3. And like you, I really hope they fix this. \$\endgroup\$ – g_b Feb 5 at 23:24
  • \$\begingroup\$ Yeah, coping the meta file is less of a huzzle than creating and importing a custom package, I will do the same. Thanks! \$\endgroup\$ – Smireles Feb 7 at 0:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.