1
\$\begingroup\$

I made a new project with the Android module installed, which works fine as I can build and run it on my phone when connected to my computer via USB, and yet can't get Unity Remote to work. Edit/Project Settings/Editor/Device won't display my phone's name. I tried several internet solutions I found (such as closing and opening again both Unity and Unity Remote or enabling PTP transfer) and none worked. Any ideas on what could be going on?

\$\endgroup\$
  • \$\begingroup\$ as I am Android developper (tnough not with Unity), I need to do some configuration on the phone for it to be recognized by some tools. For instance, you may have to turn on debugger mode (tap seven time on build version in system info, or other depending on your USB verrsion, you can google it), and probably, after that, enable USB debugging (in the menu USB menu that is available when phone is connected, exact location depends on which android version you have) \$\endgroup\$ – Pac0 Feb 2 at 20:07
  • \$\begingroup\$ I already did that. Also, as I said, I can build and play games on my phone straight from Unity, so Unity-mobile communication is clearly not the problem here \$\endgroup\$ – aramos Feb 2 at 21:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.