1
\$\begingroup\$

While setting up post processing on a project that I am currently working on, I discovered that post processing effects are not visible on the apk build on mobile.

I setup a new Project with URP on Unity 2019.3.0f5 and increased the post processing bloom effect intensity, it works just fine on the editor/play mode, however, it is not visible when I build to a mobile apk. Is there a different way of setting up post processing specifically for mobile?

Here are screenshots:

[1]: https://i.sstatic.net/uKm5d.jpg - Mobile build screenshot(post processing effects are not visible)

[2]: https://i.sstatic.net/ivQrQ.jpg - Unity editor/play mode screenshot(post processing effects are visible)

\$\endgroup\$
3
  • \$\begingroup\$ Is there an update to this question? Have you solved this? If so, how? Thanks. \$\endgroup\$
    – Joseph
    Commented Nov 4, 2020 at 19:24
  • \$\begingroup\$ Took me 3 months to come back here...sorry, but no, post processing bloom doesn't work with mobile phones because of the differences in rendering paths. \$\endgroup\$ Commented Feb 25, 2021 at 7:07
  • \$\begingroup\$ It's possible that you're building to OpenGLES 2, bloom works on OpenGLES3. Disable "Auto graphics API" on your player settings and manually add OpenGLES3 then OpenGLES2. Also make sure that if HDR is enabled in your default URP asset if you're using URP. \$\endgroup\$ Commented Feb 25, 2021 at 7:14

0

You must log in to answer this question.

Browse other questions tagged .