0
\$\begingroup\$

I"m making a character in Blender where there's a character mesh and a simple skirt.

The skirt has a different material slot, which allows me to use the Unreal Clothing tool. I created the clothing data, applied it, painted it so the top part isn't moving at all and bottom has 100 "dynamics".

I also created a physics asset, however no matter what settings I try, the skirt will always poke through the thighs like they don't exist. All the colliders are capsules. I also get the feeling that the hip collider actually works. But only that one!

The skirt works perfectly with the wind, which makes it even weirder.

Does anyone know what can cause this?

\$\endgroup\$
2
  • \$\begingroup\$ We do not mark questions as solved by putting [Solved] in the title here. Clicking the green checkmark to mark an answer as Accepted, as you've already done, is enough. \$\endgroup\$
    – DMGregory
    Jul 11, 2020 at 3:14
  • \$\begingroup\$ Thanks - I often see the [Solved] next to the title, and I thought that it has to be put in manually! \$\endgroup\$
    – lilKriT
    Jul 11, 2020 at 18:41

1 Answer 1

1
\$\begingroup\$

I managed to find a solution. Turns out there were a couple of things to do:

  1. First, proper scaling in Blender - I had a proper scale of the character. But after parenting it to a skeleton, the scale went crazy once again.
  2. Second, I used the wrong type of collider.

Solutions:

  1. Don't bother scaling the mesh initially. Scale the skeleton (apply scale), parent mesh to the skeleton, then apply scale to the mesh.
  2. Only use tapered capsule and not the regular capsule in the Unreal Physics Asset.

One more tip, if the cloth still doesn't work - use "reimport base model".

\$\endgroup\$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .