0
\$\begingroup\$

Basicaly, title. I want to change the second Horizontal entry in the Input Manager but when I do it won't save the changes afterwards. I rename the second Horizontal axis to "Strafe", and I'm reffering to it in the script like that, but when I run the game I get this error: "Input Axis Strafe is not setup". This is because there's not input axis called "Strafe", because Unity just reset the default settings for some reason. There's no save button on this window, and I actually got it to save one time and it worked, but the next time it didn't and it reset the axis again! How can I avoid this?enter image description here

I set it up nicely:enter image description here

Then it screws me over after running the game once:enter image description here

\$\endgroup\$
2
  • 1
    \$\begingroup\$ once a user found this problem, he simply bring all the asset in new fresh project and it resolved. \$\endgroup\$ – Muhammad Faizan Khan Jan 24 '20 at 5:20
  • 1
    \$\begingroup\$ The save button for these settings is under File -> Save Project. It may be worth peeking in your project settings folder and verifying that the input manager file hasn't been set as read-only or denied write permissions for your user ID. I've had an issue in the past when editing a project from multiple local user accounts where one would steal ownership of a file and block the other from seeing anything but defaults when building the game. \$\endgroup\$ – DMGregory Jan 24 '20 at 6:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.