0
\$\begingroup\$

I am trying to follow this mini tutorial and I can detect an image and replace it with my 3D object. The object is an AR Session Origin tracked image prefab, but when I try to add a Video Player instead, nothing happens.

I was using Unity 2019.2 and got an error when trying to put the video player on the object, then searched about it and Unity fixed that issue on 2019.3.

I am now using 2019.3 and don't get the error anymore, but there is also nothing on the screen when the image is detected.

\$\endgroup\$
2
  • \$\begingroup\$ Kindly, did anyone find a solution for this problem? any video or tutorial for play video on Marker's image? Thanks in advance! \$\endgroup\$ – Help Me in GIS Jan 29 at 22:41
  • \$\begingroup\$ there is nothing on screen when image detected Either the prefab isn't even being spawned, or it is spawned but not visible. Personally I suspect the latter, but regardless first determine whether or not the prefab is instantiating. For example, put a script on it that prints a message to the console in Start() \$\endgroup\$ – jhocking Jan 30 at 1:15
0
\$\begingroup\$

Maybe you're not doing it wrong if you're not getting any error. Did you check the AR Foundation samples?

I'm sure there is an example of a video player.

Make a prefab and add that prefab by instantiating the object on the target image.

If you are still getting the issue, let me know, I'll make a video for you.

\$\endgroup\$
2
  • \$\begingroup\$ I have the same issue and cant find a video player example in the samples files, can you help me? \$\endgroup\$ – spqx Sep 15 '20 at 11:00
  • \$\begingroup\$ Are you trying to play video on Marker's image, Am I right? \$\endgroup\$ – Hardik Sep 16 '20 at 15:09

Not the answer you're looking for? Browse other questions tagged or ask your own question.