1
\$\begingroup\$

I have a scene in Unity (2019.3.0f3 Personal) using the High-Definition Render Pipeline. There are no lights in the scene, and Baked Global Illumination is disabled. The skybox is a GradientSky. By all means, the lighting in the scene should be absolutely uniform, but instead there is a gradient from one side to the other.

This is what the scene looks like: normal scene

Though the effect is faint, you can see that the right side of the plane is slightly lighter than the left. The ground shader is HDRP/TesselationLit, and by bringing the Smoothness Remapping to max I can exaggerate this effect, as shown below. This is why I am under the impression the effect is specular in nature.

increased smoothness

Interestingly, if I switch the camera to the Isometric mode, the effect disappears:

isometric mode

Finally, the effect appears to occur in world rather than camera space, as shown by the changes in lighting when I rotate my camera in increments of 90 degrees:

rotations of camera

What is causing this effect, and how can I disable it?

\$\endgroup\$
1
\$\begingroup\$

I ended up solving the problem on my own. The texture type of normal map for the material assigned to the ground was set to Default, and setting it to Normal map resolved the problem. Duh...

| improve this answer | |
\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.