0
\$\begingroup\$

I'm having an unusual reaction from trying to bake my scene for Occlusion Culling (the scene was starting to lag and I thought this would optimize it) and I wanted to ask for advice.

What's happening: This scene and the previous scene are very similar in structure and appearance, only one scene has 2 large models in it. I selected every model/object in the scene that wasn't a character, or had any animation, set it to static, then clicked 'bake' (according to the tutorial I was following and the previous being very successful) and this is where it starts going wrong.

In the previous scene, beside Auto Generate Lighting On is a loading bar, which had 126 Jobs Remaining and took about an hour and a half to do (I was watching a show and each was 30 minutes long, I saw 3 before it completed) but this time, it showed:

Baking... [ETA: 10:26:20]

And when it first started, it had 9 hours instead, then spiked up to 11 after 30 minutes. I'm not sure why there's such a dramatic difference between the two and with my very limited experience on this, I wanted to ask for advice from more experienced Devs.

edit: This is a screenshots of everything that appears in the static dropdown menu: enter image description here

\$\endgroup\$
  • 1
    \$\begingroup\$ In the top-right corner of the Inspector where it says "Static" you have a drop-down. What happens if you keep Occluder/Occludee static on, but disable GI / reflection probe on some of these objects (where appropriate)? \$\endgroup\$ – DMGregory Dec 22 '19 at 13:11
  • \$\begingroup\$ @DMGregory I'm not too sure where that would be appropriate (I am super new to baking) could you give me an example of what sort of objects I should disable the GI / reflection for? Such as water, flora, buildings, etc? \$\endgroup\$ – CraftyMaelyss Dec 24 '19 at 0:03
  • 1
    \$\begingroup\$ It's more a factor of what you need GI/reflection for in your game context / to achieve your visual goals. My best guess was that you had some objects that had been excluded from lightmap baking previously (possibly very complex objects with lots of polygons for example), that got lumped into lightmap baking when you set them to be static for occlusion. This drop-down allows you to be more granular about what specific kind of "static" you need. Did you have any of these objects that were not static previously? If so, those are good candidates to try excluding from lightmap baking first. \$\endgroup\$ – DMGregory Dec 24 '19 at 0:57
  • 1
    \$\begingroup\$ Another thing you can try is to roll back to the version of your scene before you tried adding occlusion, and start marking "static" just one group of objects at a time, watching the bake timer with each step. If you see a jump, that's a good sign that some of the objects in that group are responsible for spiking your bake time, then you can look closer to investigate why, which object(s) in that group are to blame, and what makes those objects different. \$\endgroup\$ – DMGregory Dec 24 '19 at 0:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.