I've got a 2D Unity game I've been working on. The development computer is hooked up to a TV that supports HDR. If I turn on the "Play HDR Games and Apps" switch in windows then run the build version of my game the colors all appear overly bright and washed out. It looks fine in the editor though and looks fine when the windows HDR mode is turned off. Is there a setting in Unity that can stop this problem?

Player Settings

  • \$\begingroup\$ How have you configured your rendering in Unity so far? eg. What colour space are you using for blending, and other project settings? \$\endgroup\$
    – DMGregory
    Dec 17, 2019 at 12:32
  • \$\begingroup\$ Under project settings => graphics I have all three tier settings set to default values which is standard shader quality set to high; reflect project box projection, reflection probes blending, detail normal map, enable semitransparent shadows, enable light probe proxy volume and cascaded shadows turned on. Prefer 32-bit shadow maps and use HDR are off. HDR mode is HP16 and rendering path is forward. Realtime global illumination CPU usage is medium for High (tier 3) and low for the other two. Under project settings => player is set to use gamma for color space. \$\endgroup\$ Dec 17, 2019 at 19:26
  • \$\begingroup\$ If you meant something else please tell me. I've been leaving Unity to run at default values for the most part so I'm not overly familiar with it's innards. \$\endgroup\$ Dec 17, 2019 at 19:59
  • \$\begingroup\$ This looks like a place where a picture is worth a thousand words, so you don't have to type out all your settings. The particular one I was asking about is described here \$\endgroup\$
    – DMGregory
    Dec 17, 2019 at 20:14
  • \$\begingroup\$ @DMGregory I've added an image showing my settings. \$\endgroup\$ Dec 17, 2019 at 20:30


You must log in to answer this question.

Browse other questions tagged .