These were my steps.
Created an empty code project in UDK4.
The editor starts up.
On the left bottom you have:

![enter image description here

If you try to right click on C++ Classes,
Or select [Add New] while having C++ Classes highlighted
The option to add a new folder is greyed out.

This seems odd, since you can add a new C++ Class and set your sub folder in there. When the class gets created and our IDE in my case (Visual Studios) opens up the folder gets created in there no problem. I also tried setting the public or private option when making a new c++ class that just added a sub folder of /private /public where my new class gets nested in code but still not seeing the folder format display on the Unreal Editor.

So what's going on with UDK4? It seems highly unlikely that the issue is actually a bug.
Is it something I'm doing wrong? Or some second step I need to do?

Different Attempts:
1) Tried making the sub folder in the class create pop up, that created the folder in Visual Studios but still did not show up in the Unreal Editor
2) Restarted Unreal Editor to see if it would refresh the folder hierarchy, no luck.
3) Shutdown both UDK4 and VS and restarted UDK4 then VS also tried VS then UDK4 just in case as a second test.
4) Attempted to drag and drop a folder into the hierarchy from Visual Studios you just get a red O with a slash next to the mouse icon stating it wont allow it.


2 Answers 2


You should create a folder when you are creating/adding the class, in the dialog message when it asks for the class name you can add a folder to the path.

In case that after the restart of UE4 the folder doesn't appear there could be 2 things: 1) UE4 will reflect only UCLASS files and folders - (if the folder doesn't contain any UCLASS it will not show in editor).

2) Sometimes you have to regenerate project files so UHT will pick up the newly created objects. -- Don't forget to close both UE4 and VS before doing that.


This is normal behaviour. All the C++ files header files have to be in the same folder so that Unreal can find them (and I presume VS as well) so it prevents you from adding sub-folders.

  • \$\begingroup\$ You can add as many subfolders as you wish. \$\endgroup\$ Commented Dec 8, 2019 at 9:48
  • \$\begingroup\$ @ColdSteel You are correct. I was thinking about when you right click in the Content folder and try to add one there. The New Folder option is greyed out. \$\endgroup\$
    – Stephen
    Commented Dec 10, 2019 at 12:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .