0
\$\begingroup\$

Just installed Unity 2019.11.f1(Personal)[Window10/64bit-Dx11 on Dx10] and ran the sample "Lightweight rendering pipeline" Construction Project.

At the start,the game navigation keys [W-A-S-D] worked but the navigation was slow.
So on changing the Quality settings[Edit-ProjectSettings-Quality] from default "High" to "Low", the game navigation keys have got disabled and the console throws the following error-

Converting invalid MinMaxAABB  

On reverting back to the working "High" quality settings , the navigation controls no longer work.
How to resolve this issue?
enter image description here

\$\endgroup\$
  • \$\begingroup\$ If you repeat the same steps on a new project, does the same behaviour occur? \$\endgroup\$ – TomTsagk Dec 3 '19 at 11:13
  • \$\begingroup\$ Yeah,Nav controls do work on a New Project .My guess is the errors were possibly due to the additional installed assets like Shader & Vfx graph which were added to the sample project .Since it is a Dx10 Gpu ,probably there are some compatibility issues in Lwrp projects with these assets. \$\endgroup\$ – starzar Dec 3 '19 at 14:00
  • \$\begingroup\$ This is very important information that should be somewhere on the question. Otherwise others will try to guess if something went wrong while installing Unity, which seems like is not the issue here. \$\endgroup\$ – TomTsagk Dec 3 '19 at 14:02
  • \$\begingroup\$ This is not an Answer but just a Guess .Any ways, if some one refers to this question ,they most probably will read this comment. If required ,this issue could be closed by posting the above comment as an answer. \$\endgroup\$ – starzar Dec 3 '19 at 14:07
  • \$\begingroup\$ The problem is its not an answer. New people reading this question, shouldn't have to go through the comments to complete the question. Keep in mind users here are volunteers, and if they read a question that is missing important details, they will most likely skip it, without even reaching the comments. If your issue is being created by installing additional packages in a project, then edit your question to focus on that problem. \$\endgroup\$ – TomTsagk Dec 3 '19 at 14:19
0
\$\begingroup\$

NOTE- Reader's are requested to check performance of the below mentioned Packages in their own LWRP(light weight rendering pipeline) project,before not installing/uninstalling them.

Eventhough Unity's new Vfx/Shader Graph info shows support for LWRP projects in the Package Manager ,but if the computer's GPU does not support DX11(eg Dx11 on Dx10),some issues/errors may occur which may not be obvious.

Obvious error's

Shader Graph

Compute shaders not supported on Gpu

Vfx Graph

Vfx rendering requires compute shaders,no rendering will occur.    

Weird Issues

However,along with no support for Shader/Vfx Graph ,there are some weird issues.

-Game Navigation Controls (W-A-S-D)get disabled,resulting in complete stalling of development.

-Also,following error is repeatedly thrown by the console

Converting invalid MinMaxAABB    

However,on uninstalling the Vfx and Shader graph packages from the LWRP project , the game runs fine.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.