0
\$\begingroup\$

I am using VSCode but I have also tried Visual Studio 2019 to write code for Unity, but when I'm writing the lines I don't get dropdown menus with for example the methods this class holds. Or objects. Or it's properties. etc.: basically, IntelliSense is not working.

Is there a setting that I need to enable in order to get those? Since I've seen everyone who use VSCode and visual studio get these dropdown menus.

\$\endgroup\$
0
\$\begingroup\$

Here are the things I have had to do to solve this issue before:

  • Make sure you have Visual Studio Code set as your editor in the unity preferences.
  • Make sure you have the C# Visual Studio Code extension installed.
  • Check the VSCode OmniSharp logs for any errors.

Let me know if this helps.

\$\endgroup\$
  • \$\begingroup\$ everything is as it should be, C# extension is installed and enabled, I didnt find any errors from OmniSharp and VScode is the default IDE for Unity scripts. I reloaded and restarted VScode and still no changes. \$\endgroup\$ – Denislav Karagiozov Nov 6 at 16:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.