I'm using Visual Studio 2017, Unity Hub to 2.1.3 and just created a project using Unity's 2019.2.11.f1 version.

Once trying to open a script in Unity, it doesn't open and then I'm forced to use Task Manager to End Unity's task because can't even close it normally due to not being able to interact with the screen. No errors or warnings, VS doesn't open, can't interact with Unity anymore.

This doesn't block me from working, it just isn't as convenient as before.


1 Answer 1


I managed to solve it by going through all the next steps.

  1. Did some research and found a thread where people write about going through similar or the same problem but didn't really gave me an answer.

  2. Restarted Unity and ensured all packages are updated, but the problem remained.

Package Manager

  1. Downgraded the project to 2019.2.7f2 and to 2019.2.1f1 (in Unity Hub), but this wasn't enough.

Unity Hub

  1. I tried to open the script in VS 2017 and it opens fine.

  2. Checked possible updates in VS 2017 and ensured it's up-to-date.

Visual Studio Installer

To note: It's possible that the problem could have been solved right away just by updating the VS 2017.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .