0
\$\begingroup\$

I'm trying to create a custom mesh and rig in stock Blender 2.8 and export it via .fbx to stock UE 4.23. Unfortunately, the bones of the skeleton end up in entirely the wrong place.

enter image description here

enter image description here

enter image description here

In short, the bones behave strangely. From what I can tell, the child of the root bone seems to fold into the root, dragging along all its own children. The weirdest part about this is that everything works perfectly fine in UE4. The animations work and so does everything else (aside from the usual scaling woes), only that added sockets end up in the wrong place. If I try to transform any of the bones in any way, the mesh goes completely haywire.

I already watched Epic's latest stream on this topic and tried to replicate the thing from that stream, but it has the same problem. I tried renaming the Armature to "Root", having a separate root bone, having no dedicated root bone at all, moving the rig and mesh around, applying those movements, having different spots for the pivot point set, different combinations of all those, in addition to trying different Blender->UE pipeline "tricks" from earlier Blender versions like playing around with the scaling, but nothing has any effect. From what I have gathered, renaming the Armature or messing with Blender's scaling isn't a wise choice anyway, since apparently this can cause severe problems down the road.

I'm starting to run out of ideas, hopefully somebody can help me out.

\$\endgroup\$
  • \$\begingroup\$ Make sure you are exporting with X forward Z up axis \$\endgroup\$ – ColdSteel Oct 27 at 12:00
  • \$\begingroup\$ I tried that, but it doesn't seem to change anything at all unfortunately. A post on the unreal forums led me to take a closer look at the default Epic skeleton and it looks like that suffers from the exact same issue. It's possible that this is just Unreal's countr-intuitive way of displaying bones, showing them as bone foot to bone foot from parent to child, and not where the bone is actually pointing to. I'm still trying to figure out if that's true, it just seems so entirely alien to me and I don't understand why it'd be set up this way. \$\endgroup\$ – Star Hunter Oct 27 at 13:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.