0
\$\begingroup\$

So I have a game on app store, I added Google play services

Now when I do an apk build and test it works great really happy with it.

But when I then tick the box for aab ( this is what Google store want uploaded ) it builds it, I upload it, it rolls out but the Google play stuff fails to work, leaderboard and sign in.

When I extract the apk on my Mac from the aab and install that it works great again.

What am I doing wrong? Is there a way to check logs of running app? On a device

I have tried

7 different versions of unity (currently on 2019.2.9f1) Changing the min version of Android API to 21 I exported it as a Gradle project and tried building it like that, again test great on device but play services fail when downloading it from the google play store.

It's using the IL2CPP scripting backend.

Any ideas at this stage are welcome

\$\endgroup\$
0
\$\begingroup\$

so after you upload it, google resigns it and gives you a new cert to I had to take this and put it in my google play services API.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.