Would like to avoid using separate action mappings i.e. MouseWheelUp and MouseWheelDown for a system I'm developing.

I noticed MouseWheelAxis and put that as my axis event. This only works on the forward movement of the mouse wheel, and not on the backwards, as stated. (presumably because the scale is set to +1.0)


And how can I get around this?


1 Answer 1


It's not possible to assign the mouse wheel scrolling action to a regular axis mapping as you would do with two different keys.

The only option available is using MouseWheelUp to scale +1.0 (or what you need) and MouseWheelDown to scale -1.0.

This is by design and is not considered a bug.

Edit based on my own tests and from new comments.

I'm not sure why you're only seeing result when the wheel moves forward.

I went into the input settings and added a new axis event based on mouse wheel axis: UE4 Unreal 4 Add new Input Binding

Then went into the level blueprint and set up a simple chain for getting to a print string: UE4 Unreal 4 MouseWheelAxis Blueprint BP

And finally, ran the program, scrolling the mouse wheel back and forth: UE4 Unreal 4 MouseWheelAxis screen result

As you can see, I'm getting 1.0 and -1.0 results so can't say why you're not seeing the same.

Please note that I'm using engine version 4.22 for this. Based on previous research, I didn't think this was possible so it may be a new feature added on a later version of the engine.

  • \$\begingroup\$ Ah I'm so sorry, the first sentence should read 'separate action mappings'. As the two specified do not work in unreal's axis mappings \$\endgroup\$
    – Natalo77
    Oct 16, 2019 at 11:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .