0
\$\begingroup\$

I created a project to download and try out free Unity assets. I then transfer the assets I actually want to use to my actual project which uses the LWRP render pipline.

I tried to get some particle system. I copied all settings and then I found that the shader "Standard Unlit" is not working in my project. I tried to use the LWRP shaders but they didn't give me the same results. How to solve this?

screenshots

\$\endgroup\$
0
\$\begingroup\$

The LWRP shader in your project uses "Color Mode: Additive" while the standard shader in the LWRP project uses "Color Mode: Multiply". The result is that those areas where a lot of particles with a very low intensity accumulate create a halo in your shader.

\$\endgroup\$
  • \$\begingroup\$ What you see is the best result I can get. I did what you said and the result is bad. No matter what I do I can't get close to the one in unity asset. If you have time please try download Unity Particle Pack and copy fire particles to your project as I did. Is it a bug ? \$\endgroup\$ – user43474 Oct 13 at 17:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.