0
\$\begingroup\$

I've implemented Unity IAP. I have succesfully implemented it before and all went well. Now at the moment, everything goes well except for 1 consumable. When I try to purchase it, i get the PurchaseFailureReason with value DuplicateTransaction.

After some googling, I found out that it probably is because the transaction was cleared by Google, but the callback was never invoked inside the app. So somehow and somewhere, a flag is set indicating that this transaction is still pending or something? (The purchase on the - now not working consumable - had also indeed been made before and the callback was NOT called, so this seems to be correct.)

All other consumables work fine. They are configured exactly the same, just with another reward on the callback. (Same method, different parameter. I'm 100% sure this has nothing to do with the bug).

So now I want to try and fix this product.

  • I tried reverting the purchase (even though it is a test purchase) inside Google Play.
  • I tried manually adding a restore button and clicking it.

Some info:

  • I am using Unity Codeless API.

  • Game is only available on android as of yet.

  • The bug originates from when I tried making a purchase, but (due to bad wifi) i managed to navigate to another screen before the GooglePlay popup came. This disrupted the callback somehow and probably flagged the purchase as "purchased but not completed" or something.

  • I store receipts from the products in my database so I can compare/ provide support for clients when purchases go sour. The purchase in question never arrived in my database. All corresponding purchases on the same product ID now fail with reason DuplicateTransaction

  • Consumable products are configured in Google play, online unity monetization console, in editor iap catalog. All are configured exactly the same 100%

  • The game is still in Alpha, soon going to Beta (once I fix this :)).

\$\endgroup\$
1
\$\begingroup\$

Well after leaving the app alone for an hour I launched it up again to check the Iap screen. Somehow, without pressing anything, the purchase that was somewhere pending ended up resolving, and I saw my popup indicating that the purchase completed. The purchase finally finished.

So one of my latest actions probably triggered this, which are:

  • Adding a restore button to the iap screen and clicking it.
  • Adding the products to the unity monitization console online
  • Reverting the purchase in Google play (does not seem likely)

Hope this helps anyone running into the same issue. Also if someone has more information on what probably caused this issue to resolve, that would be very helpful!

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.