2
\$\begingroup\$

I just got the latest AndEngine code from Mercurial, added Android 1.6 to my Order/Export tab, and cleaned everything (including a "Fix" command as instructed by the console). Regardless of which version of Android I specify in my project settings (1.5, 1.6, 2.2, 3.2), I get around 523 compilation errors.

The most unique I can see is ETC1 cannot be resolved, accounting for 5 out of 105 errors I can see.

The other 100 are all some variation of The method [...] must override a superclass method.

What am I missing? I installed the JDK, Eclipse classic, SDK manager, and everything in the SDK.

\$\endgroup\$
2
  • \$\begingroup\$ tried the forums? andengine.org/forums \$\endgroup\$ – Jari Komppa Sep 22 '11 at 5:26
  • \$\begingroup\$ Yeah, cross-posted to Gaming.SE and the forums. \$\endgroup\$ – ashes999 Sep 22 '11 at 10:30
2
\$\begingroup\$

You need to set the Compiler Compliance to 1.6, otherwise it will complain about almost every occurrence of an @Override annotation.

\$\endgroup\$
1
\$\begingroup\$

According to http://www.andengine.org/forums/post21672.html this thread on the andengine forums, the reason is:

Hey dude! That's because you're not using Android 2.2 in your project

\$\endgroup\$
1
  • \$\begingroup\$ I presume this means selecting "Android 2.2" in "Project Build Target." I tried this already, as I mentioned in my question, with various versions. \$\endgroup\$ – ashes999 Sep 22 '11 at 10:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.