1
\$\begingroup\$

I've been using RPG Maker XP for a long time, i think before Steam. back then to get RPG Maker XP Working you had to connect it to the net to get an Ntitles serial before you could put in the activation code.

this has been fine for the past 10-15 years where i have been running it off my Portable HDD with my projects (on Windows XP and 7). i also have gotten RPG Maker XP on Steam with a Humble Bundle that included VX, VX Ace and MV. recently i upgraded my PC now with Windows 10 and when i went to use my old copy on my Portable HDD, even when connected to the internet (and i did check the network, nothing was wrong) it couldn't get the Ntitles serial. so then i fell back to the Steam Version. this worked and didn't even ask me for a key (though downside is that i now have to have Steam running for when it starts up).

While working on my project i went to playtest and i got the error

The specified procedure could not be found

after debugging i found out that when i saved my Project, the Steam RPG Maker XP dumped a RGSS104E.dll file into my project and rewrite Game.ini to point to it. this is an issue because i use the RPG Maker XP Ace which required VX Ace's RGSS3 .dll. when i edited the .ini file my game worked with no issue and i found that if i save Game.ini with the correct library after saving my project before pressing the playtest button things work.

however keeping Notepad++ open and re-saving the file each time is a pain. ways to avoid this that i have tried are

  • Rename the RGSS3 .dll in my project folder to RGSS104E.dll - doesn't work as RPG Maker XP is dumping RGSS104E.dll overtop (confrimed as the Modified Date changes and the error returns)

  • Replace RGSS104E.dll to a renamed RGSS3 .dll in the RPG Maker XP Install Dir - doesn't work because then the Editor reports that it couldn't find RGSSInitialize

  • Do above but after the editor has started - the .dll is locked and Windows wont let me do anything with the .dll

  • Use my original copy of RPG Maker XP - the Ntitles server i suspect is dead as it wit keeps reporting the same issue while while Steam's version is installed all Projects associate with it (as such uninstalling Steam's version wont work)

So I would like to know how can i stop Steam's RPG Maker XP from rewriting my Game.ini file? if i stop it doing this then i can point to the RGSS3 .dll and just not care when it redumps RGSS104E.dll. alternatively i would like to stop RPG Maker XP to stop dumping RGSS104E.dll in my game folder as this way i can just rename the .dll

\$\endgroup\$
1
\$\begingroup\$

Unfortunately, even the pre-Steam version of RMXP likes to rewrite the Game.ini - it'll change the Library entry to refer to a dll in the root depending on the version. 104E for newer versions, and 102E or older ones. It does not, however, alter the present DLL itself.

I'm using XP Ace myself, and I would also like to fix this mostly so I can keep the dll in the System folder, but no dice. So I'm forced to have the RGSS3 dll (renamed) in the root.

The best thing I can recommend is to use the pre-Steam RMXP editor. Because the DRM is broken by this point, you'll need to either enter your registration key manually into the registry somehow, or back it up from a working install and patch it into your existing one, if you have it.

\$\endgroup\$
1
  • \$\begingroup\$ This answer would be more useful if it would explain how to do the things mentioned in the last paragraph. \$\endgroup\$ – Philipp Sep 9 '20 at 8:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.