0
\$\begingroup\$

I have a problem with the Asset Store on openSUSE Tumbleweed, running Unity 2019.1.0f2.

I can connect, log in, view the download button, and click it.

Then, a "Downloading" message appearsb but nothing more happens.

This is strange because on Arch it is working perfectly.

I disabled my firewall and other security things, without success.

\$\endgroup\$
1
  • \$\begingroup\$ its all about network connection \$\endgroup\$
    – virtouso
    Commented Aug 25, 2019 at 15:05

2 Answers 2

2
\$\begingroup\$

Well, after a hard search, I found the problem. Unity can't found

/etc/ssl/certs/ca-certificates.crt

, and symlink is needed to

/etc/ssl/ca-bundle.pem

exactly the solution is:

sudo ln -s /etc/ssl/ca-bundle.pem /etc/ssl/certs/ca-certificates.crt

From : https://forum.unity.com/threads/solved-unity-cant-connect-to-any-unity-services-and-collab-is-not-working.618199/

\$\endgroup\$
5
  • \$\begingroup\$ Its great you found the solution in your question you mentioned that download from asset store is not working but in forum its all about unity services. \$\endgroup\$
    – Swati
    Commented Aug 26, 2019 at 7:25
  • \$\begingroup\$ Yes, but the error that appears on this thread of unity forum is the same that appears on my Unity log. Seems Unity Services are related to this problem... \$\endgroup\$
    – Jordi4321
    Commented Aug 26, 2019 at 8:02
  • \$\begingroup\$ Humm. may be you'r right. \$\endgroup\$
    – Swati
    Commented Aug 26, 2019 at 8:05
  • \$\begingroup\$ Yes, executing this line on terminal solves the issue. I don't opened anything on firewall or router, all is working perfect now, except the search boxes, I can't type in, but, is a small problem, normally I'm using Firefox to do this. \$\endgroup\$
    – Jordi4321
    Commented Aug 26, 2019 at 8:26
  • \$\begingroup\$ Had this exact same problem. As per forums.opensuse.org/t/… , symlinked it to /var/lib/ca-certificates/ca-bundle.pem, that fixed it. \$\endgroup\$
    – Richlv
    Commented Apr 26, 2023 at 19:14
0
\$\begingroup\$

Try these two methods it might help:

Solution # 1: First make sure Hidden item is visible if not then do the check hidden item check box in the view. then follow the steps below:

  1. Close Unity.
  2. Deleted directory under "~/Library/Unity/Asset Store-5.x/myAssetName for windows and for Mac - User > Library > Unity > Asset Store. As you are using openSUSE which I have never used so I think you got the idea where the file will be.
  3. Relaunch Unity.

Solution # 2:

  1. close asset store in unity if opened.

  2. In your browser go to asset store and log out from your account.

  3. Log in again.
  4. Click on open in unity and it should open now.
  5. Now click on download.
\$\endgroup\$
4
  • \$\begingroup\$ Note that this user isn't on Windows or Mac, but on openSUSE, which is a Linux distribution. \$\endgroup\$
    – DMGregory
    Commented Aug 25, 2019 at 15:39
  • \$\begingroup\$ I don't have /Library/Unity folder. Project folder has a Library folder, but Asset Store is not here. Second option not worked... \$\endgroup\$
    – Jordi4321
    Commented Aug 25, 2019 at 16:36
  • \$\begingroup\$ I have never used openSUSE as i mentioned so i don't know the file system. But basically the path i mentioned is the folder where the assets you download from unity asset store exists so you need to find that folder and delete the file with the name of asset you want to download and then re download the asset. \$\endgroup\$
    – Swati
    Commented Aug 25, 2019 at 16:44
  • \$\begingroup\$ Ok I found it, is under .local/share/unity3d. I deleted the folder, and tried again, nothing changed. Unity recreates the folder but not download anything. Now, I will wait for a long time, waiting an error message maybe. \$\endgroup\$
    – Jordi4321
    Commented Aug 25, 2019 at 17:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .