3
\$\begingroup\$

enter image description here

enter image description here

I select arm64 (64 bit) and x86 and amrv7 and select build app bundle in player setting so but when I want publish so I have an error like :

Error

This release is not compliant with the Google Play 64-bit requirement

The following APKs or App Bundles are available to 64-bit devices, but they only have 32-bit native code: 2. Include 64-bit and 32-bit native code in your app. Use the Android App Bundle publishing format to automatically ensure that each device architecture receives only the native code it needs. This avoids increasing the overall size of your app.


I tried following the steps listed in this Stack Overflow post, but the problem remains. PLease answer me, why no people answer in this web site?

\$\endgroup\$
  • 1
    \$\begingroup\$ Welcome to GDSE. When I searched for the error message you listed, I found this Stack Overflow post. Does that Q&A address your problem? \$\endgroup\$ – Pikalek Aug 26 '19 at 13:58
  • \$\begingroup\$ Why no one answers me \$\endgroup\$ – afshin Aug 26 '19 at 17:02
  • \$\begingroup\$ Dear pikalek , I upload like stackoverflow.com/q/55974331 but Ihave This Error also , Why ???? I do ot kow , I test for 10 time and I have it also \$\endgroup\$ – afshin Aug 26 '19 at 17:41
  • \$\begingroup\$ I'm not totally sure what you mean by "I have this error also." Are saying that you followed the solution in the link that I posted & you still have the same error? \$\endgroup\$ – Pikalek Aug 26 '19 at 17:45
  • \$\begingroup\$ PIkalek , yes Right ,I followed the solution in the link that YOU posted & Istill have the same error Google play can ot accept my games and I see: enter image description here enter image description here I select arm64 (64 bit) and x86 and amrv7 and select build app bundle in player setting so but when I want publish so I have an error like : Error This release is not compliant with the Google Play 64-bit requirement The following APKs or App Bundles are available to 64-bit devices, but they only have 32-bit native code: 2. Include 64-bit and...... (in above post) \$\endgroup\$ – afshin Aug 26 '19 at 18:06
2
\$\begingroup\$

I received the exact same error yesterday when I tried to publish a new update of the app. Apparently Google has made some changes internally. I had done about 30 builds before for this particular app, so I couldn't fathom what the difference was.

What solved it for me was unchecking the x86 checkbox in the project settings.

This allowed my build to pass. I did get a notification that my new build would be supported by less devices. I checked the difference and the difference was '2'. From 12657 to 12655 devices.

I am not a 100% sure what the exact reason is that the x86 build is rejected, but what I read on other forums was that it had to do something with missing x64 libraries in the x86 build. (but feel free to correct me if I am wrong)

\$\endgroup\$
  • \$\begingroup\$ Immorality,Hello ,Thanks I will try for publish like you, but I have 2 questions Dd you uncheck ARMV7 also or not (Only x86)? 2-Does arm64 support x86 device (=means 64 bit support 32 bit devices) Or not ? \$\endgroup\$ – afshin Aug 28 '19 at 8:20
  • \$\begingroup\$ I only unchecked x86. Armv7 and arm 64 were left checked. I don't know about arm64 support \$\endgroup\$ – Immorality Aug 28 '19 at 8:28
  • \$\begingroup\$ Immorality ,very Thanks, ,I will test it , what is your minimum api in playersetting unity(api 16 or api 21)? because I selected 16 api. \$\endgroup\$ – afshin Aug 28 '19 at 8:38
  • \$\begingroup\$ Minimum is set to 16 for me \$\endgroup\$ – Immorality Aug 28 '19 at 10:13
  • \$\begingroup\$ I read minimum api for 64 bit is 21 in android official site so if you could publish with api 16 it is good \$\endgroup\$ – afshin Aug 28 '19 at 10:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.