2
\$\begingroup\$

I am using the Unity 2019.1.12. If I go to Edit > Preferences... > External Tools it says that the Android SDK Tools Installed with Unity (recommended).

Now I downloaded the Unity Remote 5 to my Android device and try to debug a game in Editor.

But when I run the game I see the output in the Unity console which tells:

Set-up Android SDK path to make Android remote work

So, should I unchek the check near the Android SDK Tools Installed with Unity (recommended), download the Android SDK myself and provide the path to it?

Are there any other ways to fix it? Because the Unity simplified the process of the installation of the SDK and it seems very sad that I can not use the Unity Hub for this purpose.

Thank you.

So, I went to the Unity\2019.1.12f1\modules.json file, found the path to the Unity SDK in the file. And provided the path manually. That solved the issue. But I do not like the solution, since it is supposed by the Unity Hub that the path to the SDK will be provided automatically.

\$\endgroup\$
3
\$\begingroup\$

I had the same issue, I needed to manually specify the Android SDK Tools (second checkbox). My Path is: E:\Program Files\Unity\2019.1.0f2\Editor\Data\PlaybackEngines\AndroidPlayer\SDK

Once I changed I closed out of the editor, opened Remote Player on phone (While attached to PC) and then opened my project again and it worked.

just unchecked sdk checkbox save your project close editor open unity remote to your phone open editor and run your project

\$\endgroup\$
1
  • \$\begingroup\$ I spent more than 3 hours looking for a solution , thanks a lot man \$\endgroup\$ – Amerdroid Sep 8 '20 at 19:47
0
\$\begingroup\$

I also got an issue like this, it took 2 days to solve this issue for me, but the solution is very simple,

Edit -> Preferences -> External tools uncheck the "Android SDK installed with unity" and then set the path to the Android SDK path manually.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.