I've upgraded my project to Unity version 2019.3.0a11. It complains and can't load scripts, mostly because it can't seem to load the original HDRPipeline. I want to make graphics display properly.

In Unity's instructions, they say to go to Assets > Create > Rendering and click High Definition Render Pipeline Asset and create this in the Assets folder. Problem is, Assets > Create > Rendering doesn't exist.

adding HDRP no menu item

  • I'm in Assets/Settings
  • I upgraded the High Definition RP, Post Processing, and Core RP Packages
  • Restarted Unity many times
  • Searched for a suitable asset

Here is what the package manager says:

package manager hdrp

There is an exception thrown in Unity about Shader error in HDRP/Lit: failed to open source file: 'Packages/com.unity.render-pipelines.core/ShaderLibrary/Version.hlsl' at /…/Library/PackageCache/com.unity.render-pipelines.high-definition@7.0.0/Runtime/ShaderLibrary/ShaderVariables.hlsl …

In fact, there is a whole wall of exceptions:

exceptions for HDRP

  • \$\begingroup\$ What does your package manager say about the HDRP Package? \$\endgroup\$
    – DMGregory
    Aug 10 '19 at 10:13
  • \$\begingroup\$ @DMGregory I added a picture so you can see exactly. \$\endgroup\$ Aug 10 '19 at 19:29
  • \$\begingroup\$ Have you tried removing and re-adding the package? What specific script errors are you getting? \$\endgroup\$
    – DMGregory
    Aug 10 '19 at 19:30
  • \$\begingroup\$ @DMGregory I did try removing and re-adding the packages many times (both Core RP and High Definition RP). For the script errors, they are above. \$\endgroup\$ Aug 10 '19 at 19:37
  • \$\begingroup\$ have you tried reimport all assets? \$\endgroup\$ Jan 20 at 6:17

The solution has been to completely remove all packages in the Package Manager that were awaiting download. Then, I removed High Definition RP and the Core RP Library. After restarting, I added the High Definition RP package back (minus the Core RP Library), and the menu item appeared.


I upgraded my project into 2019.2.6 version from 5.2.1 & my game play graphics didn't display properly. I used Cleared Baked Data in the lighting setting as shown below:

Lighting Setting

After that, my game play graphics display properly.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.