0
\$\begingroup\$

I am using this code below for a gradual fade into a scene/next level in Steam VR (HTC Vive) The whole idea is to cover up the scene loading icon which is viewable for 3-4 seconds, and the default Steam landscape scene. The fade (to red) works fine…BUT it comes in after the loading icon so this defeats the whole purpose of it. Is there any simple way to fix this? thanks

public class NewFade : MonoBehaviour {

private float _fadeDuration = 4f;

private void Start()
{
    FadeFromWhite();
}

private void FadeFromWhite()
{
    //set start color
    SteamVR_Fade.View(Color.red, 0f);
    //set and start fade to
    SteamVR_Fade.View(Color.clear, _fadeDuration);
}

}

\$\endgroup\$
1
  • \$\begingroup\$ Sorry to comment on old post but it's the ONLY reference I can find and hoping for some info! When I use SteamVR_Fade.View it only goes to shades of grey. Alpha works OK. I cannot get it to go to a color! Any ideas? \$\endgroup\$
    – jqwha
    May 23, 2022 at 7:33

1 Answer 1

1
\$\begingroup\$

You can prevent the Steam landscape scene, as you call it, from showing by checking "Do not fade to grid when app hangs" in Steam VR Settings.

Steam VR Settings

Ignore the other highlighted checkbox in the image above, that one does something unrelated.

\$\endgroup\$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .