-1
\$\begingroup\$

I am working on a muzzle flash with particle system where when the user fires the gun the material in the particle system will appear. The problem is that is shows really well in light but when the user is in a dark area the material or the muzzle flash does not show well. Any ideas?

\$\endgroup\$
  • 1
    \$\begingroup\$ What settings does the particle system have? \$\endgroup\$ – trollingchar Jul 28 '19 at 7:42
  • \$\begingroup\$ Don't forget to show us the rendering settings and material you're using on this particle system. \$\endgroup\$ – DMGregory Jul 28 '19 at 12:02
0
\$\begingroup\$

It seems like you are using "lit" particles which are shaded by light sources. When you have particles which fall into the "stuff that glows" category, you usually want to use "unlit" particles. "Unlit", in this context, means that they are always at full brightness and not affected by light sources.

If you are using the classic particle system, go to the "renderer" section and select a material with the shader "Particles/Standard Unlit" (like the "Default-ParticleSystem" material).

If you are already using the new Visual Effect Graph system, make sure you are not using an Output node with "Lit" in the name, like "Lit Quad Output" or "Lit Mesh Output". Use the regular "Quad Output" or "Mesh Output" instead.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for?Browse other questions tagged or ask your own question.