0
\$\begingroup\$

I have spent days trying to get baked lighting to look good. I use a simple low-poly style. No matter what I do, I get this type of effect (blotchy shadows and odd dark lines):

enter image description here

enter image description here

Here are my settings:

enter image description here

enter image description here

enter image description here

Baking a scene already takes around 4 hours, not sure I can increase the resolution any more without Unity crashing during the bake. Am I doing something wrong? Feel like Ive tried everything.

\$\endgroup\$
  • \$\begingroup\$ Have you tried stitching-together UV charts along the dark lines you're seeing? That can help you get lighting continuity across the edge. Obviously you can't unify every seam, but getting the most prominent/illuminated ones can help. \$\endgroup\$ – DMGregory Aug 17 '19 at 12:32
0
\$\begingroup\$

In my opinion, ambient occlusion is your culprit. In general, baking usually takes quite a long time; this is why render farms exist.

\$\endgroup\$
  • \$\begingroup\$ unfortunately ive tried without it already =/ same result. \$\endgroup\$ – Majs Jul 10 '19 at 21:18
  • \$\begingroup\$ Unity doc recommends 100 samples for indirect lighting. This will DRASTICALY reduce bake time. Also compressing your lightmap can introduce "unwanted visual effects" Please refer to the doc \$\endgroup\$ – Ben Jul 10 '19 at 21:23
  • \$\begingroup\$ Ive read every doc there is, and tried every combination of settings. As I said, I've tried everything I can think of... \$\endgroup\$ – Majs Jul 11 '19 at 6:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.