0
\$\begingroup\$

I am getting console errors that only have a timestamp. I am running Unity 2019.1.9f1 on Ubuntu 19.04. I have installed dotnet core 2.2.5 on my machine.

enter image description here

Here is the full error log: https://pastebin.com/7vfAK9fZ

Here is a particularly suspect part of the log:

-----CompilerOutput:-stdout--exitcode: 134--compilationhadfailure: True--outfile: Temp/Unity.TextMeshPro.dll
-----CompilerOutput:-stderr----------
No usable version of the libssl was found
/home/username/Unity/Hub/Editor/2019.1.9f1/Editor/Data/Tools/RoslynScripts/unity_csc.sh: line 64:  3902 Aborted                 
"/home/username/Unity/Hub/Editor/2019.1.9f1/Editor/Data/Tools/RoslynScripts/../../Tools/Roslyn/csc" /shared /noconfig @Temp/UnityTempFile-2773a2345220fccdfb0171165a73fa25
-----EndCompilerOutput---------------
- Finished compile Library/ScriptAssemblies/Unity.TextMeshPro.dll

How do I fix it?

\$\endgroup\$
  • \$\begingroup\$ did you at any point use Unity's error logging. Do a text for any of the logging functions. \$\endgroup\$ – ratchet freak Jul 5 '19 at 16:05
1
\$\begingroup\$

Looks like Ubuntu 19.04 is not supported https://forum.unity.com/threads/empty-log-errors-in-2019-1-0f2.669961/

\$\endgroup\$
  • \$\begingroup\$ Dangerously close to a link-only answer, but +1 anyway since the link does include a potential workaround which seems to match the LibSSL errors in OP's log \$\endgroup\$ – A C Jul 5 '19 at 19:06
  • \$\begingroup\$ Can you include this workaround in the body of the answer, in case the link rots? \$\endgroup\$ – DMGregory Jan 25 at 21:54
0
\$\begingroup\$

Check the editor log:

  • Click the console's window dropdown icon
  • Select Open Editor Log

enter image description here

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.