3
\$\begingroup\$

I downloaded a character in Mixamo without any animations and then proceeeded to download a separate FBX with animation then without any mesh, so I have 2 FBX files.

I then proceeded to add the model in my scene, add an Animator component and create a AnimatorController. I add the animation in AnimatorController. Here it how it looks like:

enter image description here

So I'm expecting the model to run upon Play and it did but the problem is how its displaying. It looks like this:

enter image description here

The running animation is playing but there's another model at the background following the running model.

I don't know what's happening and what I did wrong. Any ideas, please?

BTW, Rig animation type is set to Generic. I tried Humanoid as well, still the same.

EDIT:

Added images of Heirarchy and Assets

enter image description here

enter image description here

EDIT 2:

enter image description here

\$\endgroup\$
7
  • \$\begingroup\$ Show us your object in the hierarchy. It looks like you've accidentally stacked two instances of the mesh in your scene. \$\endgroup\$ – DMGregory Jun 25 '19 at 11:14
  • \$\begingroup\$ @DMGregory: I've added an image of the Hierarchy and I added how my Assets looks like as well. After downloading in Mixamo, I just dragged them in in my Assets folder and then dragged to the Scene. \$\endgroup\$ – g_b Jun 25 '19 at 23:13
  • \$\begingroup\$ OK, I know what's causing it but I don't know why. When I added the Mesh Filter and Renderer and assign Beta_Surface mesh to the Filter, that happens. I added the renderer because I needed Renderer.Bounds in a script I attached to this character. Everything works as I need it to though if there is Mesh Filter and Renderer attached but the Renderer is unchecked. I thought being unchecked would be equal to the renderer not attached. Clearly I am not understanding how this renderer works. \$\endgroup\$ – g_b Jun 26 '19 at 8:53
  • \$\begingroup\$ I think I get it now, there's already a Skinned Mesh Renderer and the Mesh Renderer works when unchecked because mesh is still there just isn't rendered. So I shouldn't add a Mesh Renderer because there is a Skinned Mesh Renderer but the script I'm using returns null on Renderer.Bounds without adding the Mesh Renderer. Currently, this is my problem. \$\endgroup\$ – g_b Jun 26 '19 at 9:06
  • \$\begingroup\$ I can get around this by adding a Collider and then changing code to get Collider.Bounds instead of Renderer.Bounds but I wanted to avoid calling Physics.SyncTransforms (I use object's Transform.Translate). Is there any way I can get that bounds of the Skinned Mesh Renderer (that is in the child of 'xbot' prefab) from a script that is attached to 'xbot' prefab? \$\endgroup\$ – g_b Jun 26 '19 at 10:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.