0
\$\begingroup\$

I have a material on a quad surface object that is parented to a canvas for a pause menu. The material is animated (materials on UI elements such as canvases cannot be animated because of [reasons], so I had to use a quad surface). Even though it is parented to the canvas, it gets lit by lights in the scene. So I set the lights up to ignore it. But now the quad surface appears darker than other UI elements (which are as bright as their default textures).

How do I make the material brightness for this quad object as bright as its albedo texture?

\$\endgroup\$
  • \$\begingroup\$ Did you try using one of the shaders under the "Unlit" group? \$\endgroup\$ – DMGregory Jun 21 '19 at 12:56
  • \$\begingroup\$ I forgot that was a thing and I didn't know what that thing was until now. Thank you. Make your comment an answer and I'll select you. \$\endgroup\$ – hatinacat2000 Jun 21 '19 at 20:09
  • 1
    \$\begingroup\$ Feel free to add it to your own answer. ;) I'm at work and can't type anything up on detail just now. \$\endgroup\$ – DMGregory Jun 21 '19 at 20:44
0
\$\begingroup\$

Oh. So I tried applying an emission before and it didn't work because I assumed I couldn't use the albedo texture for emission.

But this is exactly untrue.

Using the same texture you used for the albedo as an emission map gives the material the same brightness you have in a picture viewer (assuming all other scene lights ignore the material).

EDIT: a wrinkle: If you dare to adjust the multiplier, it is very difficult to be sure when you've returned to a default setting.

@DMGregory reminded me that there is a thing called an "Unlit" shader that fits this purpose exactly. Thanks to him.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.