2
\$\begingroup\$

I'm using Unity 2019.1.6f1.

When I open a new scene with the LWRP template project, I see errors from all materials in the scene. For example, the Jigsaw appears in my scene but in console window I see a message telling me:

Jigsaw_Mat material was not upgraded. There's no upgrader to convert Lightweight Render Pipeline/Lit shader to selected pipeline UnityEditor.Rendering.LWRP.LightweightRenderPipelineMaterialUpgrader:UpgradeProjectMaterials()

Screenshot of material experiencing error

All materials show this message, and I don't know what to do to fix these materials. How can I resolve this error?

\$\endgroup\$

1 Answer 1

3
\$\begingroup\$

To upgrade all the materials that can be supported by LWRP, go to:

Edit Menu -> Render Pipeline -> Lightweight Render Pipeline -> Update Project Materials to LightweightRP Materials

Note - only standard shader materials will be brought across. Lit/specialist shaders will not be converted automatically. You will see warnings in the console about those the cannot be imported.

FBX meshes with embedded materials

If you have any FBX imported objects, you will need to reimport them. The easiest way to do them is to find your FBX models in the Project window, right click the FBX and choose Reimport.

Don't forget to save once you've done that!

Tested in Unity 2019.2.0f1.

\$\endgroup\$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .