0
\$\begingroup\$

I'm (trying to) develop a plugin for Spigot Minecraft 1.14.2. I have tried putting both api-version: 1.14.2 and api-version: 1.14.2-R0.1-SNAPSHOT in my plugin.yml file however it always comes up with the following error:

org.bukkit.plugin.InvalidPluginException: Unsupported API version 1.14.2-R0.1-SNAPSHOT
    at org.bukkit.craftbukkit.v1_14_R1.util.CraftMagicNumbers.checkSupported(CraftMagicNumbers.java:252) ~[spigot-1.14.2.jar:git-Spigot-df0eb25-649921e]
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:131) ~[spigot-1.14.2.jar:git-Spigot-df0eb25-649921e]
    at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:333) ~[spigot-1.14.2.jar:git-Spigot-df0eb25-649921e]
    at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:252) [spigot-1.14.2.jar:git-Spigot-df0eb25-649921e]
    at org.bukkit.craftbukkit.v1_14_R1.CraftServer.loadPlugins(CraftServer.java:347) [spigot-1.14.2.jar:git-Spigot-df0eb25-649921e]
    at org.bukkit.craftbukkit.v1_14_R1.CraftServer.reload(CraftServer.java:803) [spigot-1.14.2.jar:git-Spigot-df0eb25-649921e]
    at org.bukkit.Bukkit.reload(Bukkit.java:576) [spigot-1.14.2.jar:git-Spigot-df0eb25-649921e]
    at org.bukkit.command.defaults.ReloadCommand.execute(ReloadCommand.java:27) [spigot-1.14.2.jar:git-Spigot-df0eb25-649921e]
    at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:149) [spigot-1.14.2.jar:git-Spigot-df0eb25-649921e]
    at org.bukkit.craftbukkit.v1_14_R1.CraftServer.dispatchCommand(CraftServer.java:707) [spigot-1.14.2.jar:git-Spigot-df0eb25-649921e]
    at org.bukkit.craftbukkit.v1_14_R1.CraftServer.dispatchServerCommand(CraftServer.java:692) [spigot-1.14.2.jar:git-Spigot-df0eb25-649921e]
    at net.minecraft.server.v1_14_R1.DedicatedServer.handleCommandQueue(DedicatedServer.java:433) [spigot-1.14.2.jar:git-Spigot-df0eb25-649921e]
    at net.minecraft.server.v1_14_R1.DedicatedServer.b(DedicatedServer.java:397) [spigot-1.14.2.jar:git-Spigot-df0eb25-649921e]
    at net.minecraft.server.v1_14_R1.MinecraftServer.a(MinecraftServer.java:956) [spigot-1.14.2.jar:git-Spigot-df0eb25-649921e]
    at net.minecraft.server.v1_14_R1.MinecraftServer.run(MinecraftServer.java:801) [spigot-1.14.2.jar:git-Spigot-df0eb25-649921e]
    at java.lang.Thread.run(Thread.java:748) [?:1.8.0_212]

however I am using the correct API version. Whenever I change the api-version in plugin.yml the error message changes accordingly.

What have I done wrong?

EDIT: https://termbin.com/u5a8 - full server log
plugin.yml:

name: choruschaos
main: com.cospox.choruschaos.main
version: 0.1
api-version: 1.14.2-R0.1-SNAPSHOT
commands:

main.java:

package com.cospox.choruschaos;

import org.bukkit.plugin.java.JavaPlugin;

public class main extends JavaPlugin {
    // Fired when plugin is first enabled
    @Override
    public void onEnable() {
    }
    // Fired when plugin is disabled
    @Override
    public void onDisable() {

    }
}
\$\endgroup\$
0
\$\begingroup\$

Remove everything after 1.14, it should look like this:

api-version: 1.14

alternatively just remove it. It doesn't really serve any purpose right now.

| improve this answer | |
\$\endgroup\$
  • \$\begingroup\$ Thanks! I'll try that in the morning (it's a bit late for me). If I remove the line it also gives an error, something like "api version not specified". Could this be to do with my debug setup? I'll test it tomorrow \$\endgroup\$ – Jachdich Jun 8 '19 at 22:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.