1
\$\begingroup\$

Background

I'm developing a (mobile) game that makes use of particle systems to display blood splashing. The particles are - like most assets (characters and whatnot) - world based which means there are different looking and behaving assets.

I use Assetbundles in order to keep the app's download size low, but the one's this question is about come shipped with the app so they're on the system after download and install.

The Problem(s)

There are two problems

1. Shading

2. Render Order

When I build the Assetbundles and use them in production, there seems to be a problem with the shading. The particles are not in transparent/cutoff mode and are displayed darker than usual.

Regarding the rendering order, I know there's a render feature 'sorting order' which I make use of. I have set it to a somewhat high value (higher than all my other objects) and it's still not being rendered in front of them.

For reference I've included pictures of my setups and outcomes.

Reference Images

This is how the particle system's assigned material appears when testing without assetbundle:

particle's material when not using assetbundle

This is how the material appears when being loaded from the assetbundle:

particle's material when loaded from assetbundle

There are two materials, but except for the sprite they share the same settings

the particle material's settings

The Assetbundle includes all of the required materials and sprites as well as the particles themselves (just to make sure)

the assetbundle's composition

When testing the particles without assetbundles (plain prefab, test build) it looks like this:

what the particle system is supposed to look like

But when built using an assetbundle, it looks like this (notice the difference in shade as well as the lack of transparency):

particle system when using assetbundle

Also, the particles are not rendered in front of other objects despite the sorting order settings:

the particle system's - shared - render settings

enter image description here

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.