0
\$\begingroup\$

I want to use an .fbx mesh to block light from entering a room (except for holes cut for windows). The mesh itself must stay invisible. I know marking it "shadows only" will hide it from the camera, but light still passes through it unless I mark the mesh as "lightmap static" as well. The problem is that this is a huge mesh that doubles the number lightmaps required, and it won't even be seen. Is there a better way to do this?

I am using the Lightweight Render Pipeline in Unity 2019.1.4f1 on Windows 10. Using CPU to render on an Intel Core i5 laptop.

directional light will enter 13 windows

"Shadows" changed to "on" so mesh can be seen

\$\endgroup\$
0
\$\begingroup\$

Checked over the options again in the Scene panel of the Lighting settings. Figured out that solution is to set "Scale in Lightmap" from "1" to "0". Hovering your mouse over this option even says that this will make it so the object does not recieve light in the scene but still contributes to the lighting of other objects in the scene, which is exactly what I want.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.