0
\$\begingroup\$

Smoothness slider is not active. Why and how to make it active?

enter image description here

\$\endgroup\$
1
\$\begingroup\$

Consulting the Unity documentation on the Simple Lit shader, it says:

Simple Lit Shader

Use this Shader when performance is more important than photorealism. This Shader uses a simple approximation for lighting. Because this Shader does not calculate for physical correctness and energy conservation, it renders quickly.

And following that second link:

Simple Shading

This shading model is suitable for stylized visuals or for games that run on less powerful platforms. With this shading model, Materials are not truly photorealistic. The Shaders do not conserve energy. This shading model is based on the Blinn-Phong model.

In this Simple shading model, Materials reflect diffuse and specular light, and there’s no correlation between the two. The amount of diffuse and specular light reflected from Materials depends on the properties you select for the Material and the total reflected light can therefore exceed the total incoming light. Specular reflection varies only with camera direction.

Light attenuation is only affected by the light intensity.

So, to unpack that a bit:

"Smoothness" is a physically-based way of describing how the material divides incoming light energy between diffuse reflection (rough materials that scatter light all over) and specular reflection (shiny materials with mirror-like reflection)

Since the simple lit shader does not use a physically based model, it does not use the smoothness slider in quite the same way as the other built-in materials.

Under the "Advanced" parameter fold-out, you'll find a checkbox for "Specular Highlights"

  • If this is unchecked, then the object is rendered with pure diffuse rendering (ie. maximally rough), and the specular map, specular colour, smoothness, and smoothness source parameters are all disabled.

  • If this is checked, then the specular colour/map parameters affect the colour & brightness of the specular highlight (often called the "specular colour" or "specular intensity" in Blinn-Phong shaders), and the smoothness slider affects the size/sharpness of the specular highlight (often called "specular power")

So, what you can do if you need control over smoothness:

  • Switch to the "Lit" shader to use physically-based shading, at a higher rendering cost (profile to find out if this is an issue for your game on your target hardware)

  • Stick with the "Simple Lit" shader, and check the "Specular Highlights" box to enable using the slider to control specular power to approximate smoothness, if this Blinn-Phong approximation is sufficient for the look you want

  • Or, if neither of these options gives you the look you want with acceptable performance, you can create a new custom shader using these shaders as a starting point, and implement your own lighting model to give you the appearance-vs-performance balance that you need.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.