0
\$\begingroup\$

I'm trying to rearrange my layers in Unity but I can't seem to drag them. When I try to do this I'm in edit layers under the heading sorting layers and I click on the = symbol and try to drag it but it won't move. I also tried restarting Unity twice but it won't resolve the problem.

Could someone help me with this?

enter image description here

\$\endgroup\$
7
  • \$\begingroup\$ This looks very similar to this question that was asked recently. Can you show us a screenshot of what you're seeing? \$\endgroup\$
    – DMGregory
    May 19, 2019 at 7:30
  • \$\begingroup\$ Dragging up and down anywhere on those layers except the text box field should move the layer. Possibly have a saved preset overriding the order? or a editor script that is forcing the sorting order? that would most likely cause them to stay in place and not move. \$\endgroup\$ May 19, 2019 at 15:08
  • \$\begingroup\$ I can't reproduce this problem: when setting up the layers as shown in your screenshot, I can re-order them just fine. Can you replicate this problem in a new, empty project? If not, then as Justin says there may be something in your current project that's overriding your layer order. If it happens in a new project too, then it could be a problem with your Unity installation. You can try re-installing or reporting the issue to Unity's support team. \$\endgroup\$
    – DMGregory
    May 19, 2019 at 15:11
  • \$\begingroup\$ Out of curiosity, what version of Unity are you using? I've tried this in 2019.1.2f1 & 3f1 and it works fine, but another question reports a similar problem in an "a" version - so it might be a bug specific to that version. \$\endgroup\$
    – DMGregory
    May 21, 2019 at 1:50
  • \$\begingroup\$ DMGregory it happend as well when I tried it in a new project. I tried it at my schoolcomputer too and on there the layers just drag normally. (Unity keeps crashing and takes a really long time to load on the schoolcomputers so that's why I can only work on it on the PC at home where the problem occurs) The version that i'm using is 2019.2.0b2 \$\endgroup\$ May 21, 2019 at 13:40

0

You must log in to answer this question.

Browse other questions tagged .