0
\$\begingroup\$

I have almost nothing in my scene--in fact, I reduced my scalability settings from "High" to "Medium" before even loading my level layout--and doing this has crashed the program multiple times. It didn't crash this time, but it is telling me it is compiling over 5000 shaders (!) and my objects' materials are not showing up in the viewport.

1) that is a ton of shaders, what shaders are these? I only made like 8 shaders.

2) What is making this take so long? it is taking forever, over 10 minutes already.

3) Is this normal?

enter image description here

\$\endgroup\$
  • \$\begingroup\$ There is an option, I do not know exactly which one, but that I once modified and it made all the shadows of my project recompiled. If that's the case, it's really time-consuming. Look, I have a video card, I imagine you have it too. \$\endgroup\$ – Boneco Sinforoso May 14 at 22:50
  • \$\begingroup\$ I don't...? I am using a laptop--HP Pavillion w/ Intel CORE i5, 7th gen processor. All my graphics are rendered using the CPU.*Are the shadows being counted as "shaders"?* What does it mean by "shaders"? My shaders are not very complex and again, I only have a few of them. My scene objects are Static Meshes that I drag-dropped and ctrl-moved (duplicated) in the scene. These are instances, right? If they are not, maybe new shaders are being created? But there are only a couple dozen cubes here and only half their faces exist in the models. Also, it finally updated completely and works now. \$\endgroup\$ – hatinacat2000 May 15 at 0:43
  • \$\begingroup\$ Tomorrow I give an answer showing exactly what happened to me. There is a difference between the shadow that the instance focuses on the game floor and some details in its own mesh, even without having added material or texture. \$\endgroup\$ – Boneco Sinforoso May 15 at 0:56
  • \$\begingroup\$ Thank you, I look forward to learning more \$\endgroup\$ – hatinacat2000 May 15 at 1:25
1
\$\begingroup\$

I'm afraid I've kept him waiting in vain.

I wish I could have just made one comment, but I found it useful to bring some pictures.

I have tested and modified all scalability reference items (https://docs.unrealengine.com/en-us/Engine/Performance/Scalability/ScalabilityReference) separately and together, but I did not get the result I had and what you are getting now.

First person shooter project, blueprint of character (this was the project I had this same "problem" that you, when I was following this tutorial => https://www.youtube.com/watch?v=2sMwmEE3MuM&):

enter image description here

If I am not mistaken, it was when I activated this command for the first time (modifying all the options) that there was the delay, just like yours.

Opening the project again, the moment I was modifying each option individually, the option below gave me a delay of 5 seconds, where the message "compiling shadows" appeared the moment I released the Q key:

enter image description here

But only the first time, I tested again and it was immediate conversion, so...

I recommend not to take my answer as definitive, because when modifying only the effects option (in the individual tests), I had a delay of about 5 seconds in which the message "compiling shadows" appeared. And even after modifying everything, there was no further delay. That is, Unreal together with the computer must previously save data of these graphic changes, because there are changes, there is always this delay, but only the first time. For example, cache, temporary files.

My answer will only make sense, if and only if, you make those changes again and it does not take that long, but if you create a new project and do the conversion again, you have the delay. For then there will be a pattern in behavior.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.