Particle effects seem to move rather awkwardly when partly out of camera bounds. When scaling up particle effects to the point where they fill most of the screen they don't appear static anymore.

enter image description here
Video of the effect

I'm using particles to simulate clouds. Is there a way to fix this without scaling down the individual clouds?


1 Answer 1


This is due to the Max Particle Size property inside the Particle System Renderer component.

This setting ensures no billboarded particle ever takes up more than a configurable fraction of the viewport.

The reason for this is that large overlapping particles can be very taxing on the fill rate of your GPU. When they're only drawing a few hundred or thousand pixels each, this is pretty manageable. But as you get your camera close to a particle system and it fills your screen, each particle might be drawing to millions of pixels every frame, massively increasing the cost to draw them all.

So, for particle systems that are normally seen at a distance or take up just part of the screen (most cases), Unity defaults to scaling each particle to take up no more than half the viewport.

As you approach such a particle system, there comes a point where the particles stop growing in apparent size and instead appear to just slide sideways out of the frame - which can also help mask the "popping" you might otherwise see as the camera near plane clips through the particles.

You can turn off this behaviour when it's not desired by cranking up the Max Particle Size property, or changing the particles to draw in Mesh mode (using a quad mesh) instead of one of the billboarded modes.

  • \$\begingroup\$ Setting to Mesh mode did the trick \$\endgroup\$
    – AzulShiva
    Commented May 12, 2019 at 13:01
  • \$\begingroup\$ Increasing the max particle size also worked ! I'm also trying to simulate simple clouds \$\endgroup\$ Commented Oct 22, 2023 at 17:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .