0
\$\begingroup\$

I have some black and white, and some grayscale textures, that are loading in unity as turquoise and white textures. What is causing this and how can I fix this? Also, can somebody verify that I am supposed to load roughness textures into the "Metallic" slot of the Standard shader? That feels so weird. I was using Principled Shader in Blender to make the original materials. **EDIT: "Autodesk Interactive" shader has a "Roughness" input but most of my roughness textures and some b&w textures are still turquoise, what is happening...

enter image description here

enter image description here

enter image description here

Here is one of the problem textures (the others are too big, > 6mb):

enter image description here

\$\endgroup\$
  • \$\begingroup\$ I note that your compression mode is listed as "UNorm", so the cyan tint might simply be how the editor visualizes values outside the 0-1 normalized range. Do you observe an unexpected colour in-game, not in the editor? \$\endgroup\$ – DMGregory May 9 at 16:14
  • \$\begingroup\$ I noticed this too, these images are 64 bit (!) don't know how that is but when I open them in photoshop, there is only 1 channel for each of these images called "gray" (instead of the the standard R,G,B). How do I get rid of this compression and fix the color? \$\endgroup\$ – hatinacat2000 May 9 at 19:15
  • \$\begingroup\$ Have you tried converting the image to 8 bits per pixel greyscale using photoshop's color mode options? \$\endgroup\$ – DMGregory May 10 at 1:33
  • \$\begingroup\$ That fixed it! Thanks DMGregory. My first attempt at doing this used the Save for Web option, which was not going to cut it for the gray scale images. Don't know why it didn't imediately occur to me to change the bit depth in the Image menu. Now it works and I am re-saving all my textures as 8-bit \$\endgroup\$ – hatinacat2000 May 10 at 3:21
  • 1
    \$\begingroup\$ Great! If it's solved, please feel free to post your solution as an Answer. \$\endgroup\$ – DMGregory May 10 at 3:22
1
\$\begingroup\$

The problem seems to have been that the bit depth was too high for these images (16 bits per channel, higher for others). resolved by going into Photoshop, going to the Image tab on the menu, and setting the bits per channel to 8 (instead of 16). All textures load normally after doing this. If refreshing the scene doesn't do it, delete the old assets and drag-and-drop the updated textures. Thanks to DMGregory for suggesting this solution.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.