0
\$\begingroup\$

Steps,

Using Unreal Engine 4.21.2

1 - I created new Third Person game from the Unreal Engine template and named it FaceARSample

enter image description here

2 - I imported a skeletal mesh with blend shapes
3 - I added this to my DefaultEngine.ini:

[/Script/AppleARKit.AppleARKitSettings]
bEnableLiveLinkForFaceTracking=true

4 - I packaged the project for iOS and it was successful. I was able to deploy it to my iphone.
5 - I activated Apple ARKit and Apple ARKit Face Support plugins

enter image description here

6 - I packaged the project for iOS and it failed (error log below)

enter image description here

\$\endgroup\$
0
\$\begingroup\$

This might sound super unrelated - but do you have visual studio installed?

I noticed that on a fresh install, if you change any of the plugin settings in UE4, it will require you to have visual studio for packaging to work. (even if you go back to the default settings).

Try getting that, (to make sure you got the right version, you can try to open and of the built in scripts... it will try to open them in VS).

Try packaging again afterwards.

\$\endgroup\$
  • \$\begingroup\$ I installed Visual 2017 on both my macbook and windows laptop. I noticed my mac has High sierra 10.13.6 and Visual Studio said it requires 10.12. It installed anyway so I'm not sure if that's related. I also noticed the error points to a directory on my mac that doesn't exist. ...Intermediate->Build->BuildRules. BuildRules is missing. Could not having visual studio cause that? \$\endgroup\$ – Purp Apr 10 at 17:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.