0
\$\begingroup\$

I am reading Amazing 3D Games Adventure Set by Lary Meyers. The book is old, and I have got the .lib file compiled correctly onto my computer. The issue is, however, when I run the actual demos from the project files that he provided on the disk. He has another folder that just has the games made on it, and the files all work there, but when I run the ones that are supposed to be ready to compile, I get errors that state that one of the assembly files inside the Borland C++ folder that the program requires is a 32 bit file, which it apparently cannot run.

With the other executable files, they run the library perfectly, and I have made changes to prove that it works correctly.

The book source code(although I do not support piracy) is here

I was not the one who uploaded it, and I do have an actual copy of the book that you can get from here.

I compile the code with Borland C++ 4.0, and sometimes 4.5 works with the library.

The library works, but the source code does not work.

I also do not really know how to use that version Borland C/C++ compiler, and with the other versions (like 3.0 and Turbo C/C++ 3.1), I know enough to make basic applications and link files to them.

What could I be doing wrong?

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.