0
\$\begingroup\$

I've imported a tree to Unity that I've made in blender, but the texture of the tree is not visible. Could you please tell me how to make that texture visible? enter image description here

I am a beginer and I don't know how to actualy export it or what to select when exporting in blender. I only saved this 'maple' .blend file to my assets folder and that's it. I thought the tree would show up with the texture, but it didn't and I don't know what to do.

\$\endgroup\$
  • \$\begingroup\$ Did you try placing your texture in the Albedo slot of the tree's material? (Visible in the lower right of your screenshot) \$\endgroup\$ – DMGregory Mar 13 at 20:05
  • \$\begingroup\$ Yes, I have added it to albedo, but it looks like this i.stack.imgur.com/CwycD.png \$\endgroup\$ – Eglė Ged Mar 14 at 12:11
  • \$\begingroup\$ Looks like you neglected to enable alpha transparency on your leaf material. What happens when you do that? \$\endgroup\$ – DMGregory Mar 14 at 12:13
  • \$\begingroup\$ Thank you, I didn't know I can do such thing, it worked ^^ \$\endgroup\$ – Eglė Ged Mar 15 at 14:20
  • 1
    \$\begingroup\$ If you've solved your problem, please consider writing up the steps you used as an Answer. This can be a big help to fellow game developers who run into the same trouble you did. \$\endgroup\$ – DMGregory Mar 15 at 14:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.