3
\$\begingroup\$

I am building my project in Unity 2018.2.21f1 for Windows in architecture x86_64, with:

  • Copy PDB files | false
  • Create Visual Studio Solution | false
  • Develoment Build | false
  • Autoconnector Profile | false
  • Scrit Debuggin | false
  • Scritps Only Build | false

Mainly I built them and run because added several assets of the store and I wanted to see that there was no problem.

If at first glance everything worked fine. But I had the Task Manager open and I saw that the GPU had a lot of use 70% to 80% (I have a GTX 1080) and the game is 2D. My demo only has 22 sprites, without UI which I found very strange, so I opened the FireStorm (a Zotac GPU Manager) All the values of the graphics were extremely high (even started to sound a lot the fan) GPU core clock extreme high, GPU Temperature Very High, GPU Utilization Very High too.

But when I run the game inside the Unity editor, it's very normal values for a game with 22 sprites.

I continued making tests note that when the game is running the option of Graphic Quality in Fastest is selected by default, here the use of the GPU increases considerably 70% probe the rest and I have the following

  • Fastest 70% GPU use
  • Fast 70% GPU use
  • Simple 70%-75% GPU use
  • Good 6-20% GPU use
  • Beautiful 22-23% GPU use
  • Fantstic 22-23% GPU use

So the problem apparently is in the quality configuration. What concept can be the one that generates this problem? Everything is by default in Unity until now

EDIT

I have 5 scenes, only in 1 there is the problem. The scene has sprites that use Shader Weaver. I removed them and did the tests again. What I notice is that in the new build, when I run in fantastic I have the problem of high GPU consumption and in "beautiful" it increases to 40

Also in imported Tower Defense 2D of GOODDAY that modifies the project configuration. And a couple of days ago import 2D Shooter Bullet and Weapon System which also modifies the configuration.

In Quality Settings actualy have this

unity settings

I understand that vSyncCount limit the update rate

Because the levels with the worst performance have the "Dont sync" option set, meanwhile Good and Beatifull is in Every V Blank

\$\endgroup\$
  • \$\begingroup\$ Is there any frame rate limiting? Is Vsync enabled? \$\endgroup\$ – Ed Marty Mar 13 at 5:27
  • \$\begingroup\$ Are you using any external libraries that might be causing this? \$\endgroup\$ – TomTsagk Mar 13 at 11:38
  • \$\begingroup\$ @EdMarty I do not have the targetFrameRate configured at any point. look in the assets that I import, but they do not have references to the property either. I have configured in the levels with problems "vSyncCount = 0" I do not understand very well because it has this behavior. \$\endgroup\$ – LOOKM Mar 14 at 3:50
  • \$\begingroup\$ @TomTsagk I thought that the problem is caused by the Shader Weaver bookstore, but deactivate the 3 sprites that used it. returned to generate and the problem continued. Eilimine the 3 sprites, thought perhaps that still has some kind of processing at the graphic level to put them ready when they are activated. but the problem persisted. the other two suspicious libraries in the scene with problems are Easy Save 2 (of which I have never had problems in my projects for mobile) and InControl, which I have just begun to prove now that my target is PC \$\endgroup\$ – LOOKM Mar 14 at 3:54
  • \$\begingroup\$ Try disabling all libraries you use, and see if the problem is still there. If it's not, try enabling them one by one and see which one is causing trouble. Just because a library has worked fine in the past, doesn't mean that it will do that forever. I've had trouble with Collaborate in the past, after an update, so you can never be sure. \$\endgroup\$ – TomTsagk Mar 14 at 10:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.