0
\$\begingroup\$

I opened a blank project that came with two types of flooring, a table with two chairs and a statue.

The only things I modified was the size of one of the floors and the texture of the two floors.

When I did this, the following message appeared: LIGHTING NEEDS TO BE REBUILT (2 unbuilt objects)

I clicked on the option below (Compile Only Lighting):

enter image description here

Compilation failed (view image below), the following error appeared (0xc000007b):

enter image description here

Note that the Swarm Agent is working.

I restarted the program several times. I cleared the cache. I fixed the program. I started a new project. All this did not result in anything.

Below are some links that I researched and tried to solve the problem, doing almost everything I was told:

https://answers.unrealengine.com/questions/201327/lightning-build-failed-swarm-failed-to-kick-off.html

https://answers.unrealengine.com/questions/12975/unreal-engine-wont-launch-error-code-0xc000007b.html

\$\endgroup\$
  • \$\begingroup\$ The error code refers to a 64 bit program trying to load a 32 bit dll. One of the solutions I found was with the file D3DX9_43.dll in DirectX. Have you tried reinstalling this? \$\endgroup\$ – Stephen Feb 27 at 9:40
  • \$\begingroup\$ I downloaded both the 32-bit and 64-bit ones and I replaced them in the system32 and SysWOW64 folders respectively. I rebooted the computer. The problem persists. \$\endgroup\$ – Boneco Sinforoso Feb 27 at 23:03
  • \$\begingroup\$ I had already visited this page, but I let this attempt pass. answers.unrealengine.com/questions/12975/… \$\endgroup\$ – Boneco Sinforoso Feb 27 at 23:05
  • \$\begingroup\$ I have another project, but already created as an FPS (native to the program) in it I made several modifications (I changed textures, added objects) and even then the warning does not appear to rebuild the lighting. \$\endgroup\$ – Boneco Sinforoso Feb 27 at 23:26
0
\$\begingroup\$

I do not remember exactly what modification I did on my computer, but when I tried to open the UE4 the following error appeared:

enter image description here

(image taken from the internet)

It is not the first time that this error occurs, but there I went to solve it again (If I remember correctly I deleted the folder with the libraries (.dll) that resolved it the first time, so I had to download it again):

But before, a poetic pause... One day Albert Einstein said: Insanity is to keep doing the same thing and expect different results.

So this time I looked for another place to try to solve this error, :

(VIDEO LINK) => https://www.youtube.com/watch?v=kA4N0x4iG54

In this video the man orders to download a compressed file that contains three folders.

(COMPRESSED FILE) => http://www.mediafire.com/file/at50mz3rkobxe4i/Erro+0xc000007b.rar

You should copy all libraries from the first folder and paste them into the sytem32 folder (if your system is 32-bit) and the system32 and SysWOW64 folders (if your system is 64-bit).

Your pasting must be of the type that replaces existing files:

enter image description here

You will need to give administrator permission for the computer to do this:

enter image description here

There will be an "error", you select the "do this for all current items" box and then click ignore:

enter image description here

Once you click Ignore you will notice that there are numerous selected files. Press the delete key and enter to delete them (again you will have to provide administrator permission):

enter image description here

NOTE => For users of a 64-bit computer, you will have to do this in both folders (system32 and SysWOW64).

In the second folder of the file that the video man made available has the directX installer. I RECOMMEND NOT TO USE, BECAUSE WITH ME IT DID NOT WORK. I even had to reinstall directX.

(OFICIAL LINK OF DIRECTX) => https://support.microsoft.com/pt-br/help/179113/how-to-install-the-latest-version-of-directx

Just install DirectX.

In the third folder of the file that the video man provided, there is another installer (all versions of Visual Studio) that also did not work for me.

(OFICIAL LINK 64-bit) => https://www.microsoft.com/pt-br/download/confirmation.aspx?id=36805

Sorry, I downloaded 32-bit too, but I can not find the link.

Just install all versions of Visual Studio from Microsoft.

The video man also provides a link so you can download the three folders separately, so you only need to download the first folder: http://bit.ly/2CI3kse

That way I killed two birds with one stone.

The lighting build works and the error has been fixed.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.